Ben Stienstra

Linux, Unix, network, radio and more...

User Tools

Site Tools


lacp_between_cisco_2960_and_hp_1810

~~TOC~~

LACP between Cisco 2960G and HP ProCurve 1810G

  • Cisco: Port 47, 48
  • HP: Port 19, 20

HP ProCurve configuration

  • Using the web GUI, go to: Trunks → Trunk Configuration.
  • Select Create, Trunk Name 2960G, hit 'Apply'. Notice the trunk interface name, for example Trunk4.
  • Go to: Trunks → Trunk Membership.
  • Select Trunk4 from the drop down list.
  • Select Port Trunk (M) and LACP (L) on port 19 and 20.
  • Go to: VLANs → Participation / Tagging.
  • Tag needed VLANs on Trunk4. For example VLAN 50.

Cisco 2960G configuration

  • Enable, then configure.
    >enable
    #conf t
    (config)#
  • Enable LLDP.
    (config)#lldp run
  • Create VLAN 50.
    (config)#vlan 50
    (config-vlan)#exit
  • Configure interfaces.
    (config)#int range Gi0/47-48
    (config-if-range)#description LACP to HP 1810G
    (config-if-range)#switchport nonegotiate
    (config-if-range)#switchport mode trunk
    (config-if-range)#lldp transmit
    (config-if-range)#lldp receive
    (config-if-range)#cdp enable
    
    (config-if-range)#channel-protocol lacp
    (config-if-range)#channel-group 1 mode active
    Creating a port-channel interface Port-channel 1
    
    (config-if-range)#no shutdown
    (config-if-range)#exit
  • Configure Port-channel.
    #(config)#interface Port-channel1
    (config-if)#description LACP to HP 1810G
    (config-if)#switchport mode trunk
    (config-if)#switchport trunk allowed vlan none
    (config-if)#switchport trunk allowed vlan add 50
    (config-if)#no shutdown
    (config-if)#exit
  • Show configuration.
    #show interfaces Gi0/47 switchport
    #show interfaces Gi0/48 switchport
    #sh etherchannel summary
    #sh cdp neighbors

Configure IP address in VLAN 50 for testing

  • Configure IP address.
    #conf t
    (config)#interface Vlan50
    (config-if)#ip address 2.3.4.5 255.255.255.0
lacp_between_cisco_2960_and_hp_1810.txt · Last modified: 2014/08/12 15:25 by admin