Table of Contents
Install AIX 7.1 on P630 hardware
Update hardware
Update system firmware. New firmware can be found on the IBM fix central website.
Display current firmware
List current firmware and find out if update is available
lscfg -vp|grep -p " ROM"
Update firmware
Download firmware and start update. This requires a reboot.
mkdir /tmp/fwupdate cd /tmp/fwupdate chmod +x 70286C4F.BIN ./70286C4F.BIN cd /usr/lpp/diagnostics/bin ./update_flash -f /tmp/fwupdate/3R080425.img
Install AIX 7.1
Boot from DVD and install AIX 7.1
- Insert AIX 7.1 media
- Power on or reboot system
- After speaker beep, press 1 (SMS menu)
- Select DVD boot, this will take a while (coffee?)
- Select console, 2 or F1 for example
- Select: 2 Change/Show Installation Settings and Install
- Choose for 'New and Complete Overwrite'
- Install disk hdisk0
- 4, disable graphics software, disable system management client software
- 5, select express edition
- 0, Install with current settings
- Accept licenses
- Configure date, time, root passwd, network, etc.
Configure AIX
Prompt
For root, modify /.profile as below.
PS1="$(whoami)@$(hostname)(\$PWD)# " export PS1
For users, modify the default /etc/security/.profile and the users .profile as below.
PS1="$(whoami)@$(hostname)(\$PWD)$ " export PS1
Timezone
Change timezone
smitty chtz_user
Display timezone
echo $TZ
ntpd
Verify ntp connection
ntpdate -d ntp1.polaire.nl
Edit ntp.conf
vi /etcv/ntp.conf
Remove broadcastclient, add servers.
server ntp1.polaire.nl server ntp2.polaire.nl server ntp2.home.polaire.nl
Start xntpd
startsrc -s xntpd
Uncomment xntpd from /etc/rc.tcpip so it will start on a reboot.
Check reach, delay, offset and dips
ntpq -p
remote refid st t when poll reach delay offset disp ============================================================================== *ntp1.polaire.nl .PPS. 1 u 37 64 377 0.43 -0.806 0.03 +ntp2.polaire.nl .PPS. 1 u 35 64 377 0.40 -0.536 0.05 +ntp2.home.polai .DCF. 1 u 29 64 377 0.23 0.674 0.09
Mirror rootvg
Find current rootg and empty disk
lspv lspv hdisk0 getconf DISK_SIZE /dev/hdisk0
Add disk to rootvg, for example hdisk3.
extendvg rootvg hdisk3
Or force with -f
Mirror rootvg. This will take a while.
mirrorvg rootvg
0516-1126 mirrorvg: rootvg successfully mirrored, user should perform bosboot of system to initialize boot records. Then, user must modify bootlist to include: hdisk0 hdisk3.
Change list of bootable devices, so system can boot of both disks
bootlist -o -m normal bootlist -m normal hdisk0 hdisk3
Create boot image for both disks
bosboot -ad hdisk0 bosboot -ad hdisk3
Show rootvg mirroring
lsvg -l rootvg
PVs=2 is mirroring over two disks.
rootvg: LV NAME TYPE LPs PPs PVs LV STATE MOUNT POINT hd5 boot 1 2 2 closed/syncd N/A hd6 paging 4 8 2 open/syncd N/A hd8 jfs2log 1 2 2 open/syncd N/A hd4 jfs2 2 4 2 open/syncd / hd2 jfs2 7 14 2 open/syncd /usr hd9var jfs2 1 2 2 open/syncd /var hd3 jfs2 1 2 2 open/syncd /tmp hd1 jfs2 1 2 2 open/syncd /home hd10opt jfs2 1 2 2 open/syncd /opt hd11admin jfs2 1 2 2 open/syncd /admin lg_dumplv sysdump 16 16 1 open/syncd N/A livedump jfs2 2 4 2 open/syncd /var/adm/ras/livedump
Install man pages
Install infocenter.man.EN_US filesets
Configure SSHD
- Disable root login
- Add AllowUsers directive
Add empty disks to LVM
Create volume group
mkvg -y datavg -s 4 hdisk1 hdisk2
Create logical volume
mklv -t jfs2 -y optlv datavg 100
Show lv
lsvg -l datavg lslv optlv
Create filesystem
mkdir /mnt/opt crfs -v jfs2 -d optlv -m /mnt/opt -A yes
Mount filesystem
mount /mnt/opt